Categories
Apple Errors Software

Adium refusing to remember passwords

I reinstalled my Mountain Lion, and since then Adium keeps asking for passwords on every Adium restart/startup. Understandably, this is quite annoying.

I’ve tried the following:

  • readd the accounts
  • reinstall adium
  • run keychain first aid
  • check this
  • reboot
  • pray to the gods, old and new
  • check console (which is spawning a thousand million errors about read access denied, but Google told me it’s a known Mountain Lion bug)
  • update to Mountain Lion 10.8.2

What I did to solve it (I believe):

  • Uninstall Adium completely (tada)
  • install 10.8.2 (well, I happen to reboot just after uninstalling and reinstall Adium, so I’m unsure whether the first or 2nd point was most useful).

And it’s now working correctly. So far.

Downside: have to readd all accounts (Google 2-step verification fun, and time to delete those old accounts (xmpp/icq) where I forgot the passwords), and reset all your settings.

Edit: it has been confirmed by Adium it’s enough to just upgrade to Mountain Lion 10.8.2 to solve this problem. No need to delete all your settings & accounts like I did… 😉

Categories
Apple Errors Software www

Adium & Facebook

If you’re like me, and been unable to log in to your Facebook chat through Adium for months… This is the fix:

Basically, when adding your Facebook account, Adium opens some webpage asking you to login. I always logged in using my e-mail address (as… that was what the page was actually asking!).

I always managed to successfully login. Facebook then asked to identify my device (“Adium” or whatever).

However, here the problems started. Whenever I clicked save, I just ended up on the same page again, asking me to fill in my device name.

Checking my devices in Account Settings, I saw a million Adiums got added (because of my spam clicking/trying)…

I even tried to disable the “login approvals”, thinking that had something to do with it… But alas.

 

Thinking it had something to do with cookies (session cookies not/wrongly saved or something by Adium) I updated to betas… Many times, and still no fix. This was becoming annoying and pretty odd. Was I the only one have this problem?

 

I then tried, instead of using my email address, to use my actual account name (“facebook.com/YOUR-ACCOUNT-NAME”). And guess what… 😉 Yea, I could log in, add the device correctly, and Facebook chat went online right away.